upgrade_all() – Functions to be called in installation and upgrade scripts.

You appear to be a bot. Output may be restricted

Description

Functions to be called in installation and upgrade scripts.

Contains conditional checks to determine which upgrade scripts to run, based on database version and WP version being updated-to.

Usage

upgrade_all();

Parameters

Returns

void

Source

File name: wordpress/wp-admin/includes/upgrade.php
Lines:

1 to 100 of 161
function upgrade_all() {
  global $wp_current_db_version, $wp_db_version;

  $wp_current_db_version = __get_option( 'db_version' );

  // We are up to date. Nothing to do.
  if ( $wp_db_version == $wp_current_db_version ) {
    return;
  }

  // If the version is not set in the DB, try to guess the version.
  if ( empty( $wp_current_db_version ) ) {
    $wp_current_db_version = 0;

    // If the template option exists, we have 1.5.
    $template = __get_option( 'template' );
    if ( ! empty( $template ) ) {
      $wp_current_db_version = 2541;
    }
  }

  if ( $wp_current_db_version < 6039 ) {
    upgrade_230_options_table();
  }

  populate_options();

  if ( $wp_current_db_version < 2541 ) {
    upgrade_100();
    upgrade_101();
    upgrade_110();
    upgrade_130();
  }

  if ( $wp_current_db_version < 3308 ) {
    upgrade_160();
  }

  if ( $wp_current_db_version < 4772 ) {
    upgrade_210();
  }

  if ( $wp_current_db_version < 4351 ) {
    upgrade_old_slugs();
  }

  if ( $wp_current_db_version < 5539 ) {
    upgrade_230();
  }

  if ( $wp_current_db_version < 6124 ) {
    upgrade_230_old_tables();
  }

  if ( $wp_current_db_version < 7499 ) {
    upgrade_250();
  }

  if ( $wp_current_db_version < 7935 ) {
    upgrade_252();
  }

  if ( $wp_current_db_version < 8201 ) {
    upgrade_260();
  }

  if ( $wp_current_db_version < 8989 ) {
    upgrade_270();
  }

  if ( $wp_current_db_version < 10360 ) {
    upgrade_280();
  }

  if ( $wp_current_db_version < 11958 ) {
    upgrade_290();
  }

  if ( $wp_current_db_version < 15260 ) {
    upgrade_300();
  }

  if ( $wp_current_db_version < 19389 ) {
    upgrade_330();
  }

  if ( $wp_current_db_version < 20080 ) {
    upgrade_340();
  }

  if ( $wp_current_db_version < 22422 ) {
    upgrade_350();
  }

  if ( $wp_current_db_version < 25824 ) {
    upgrade_370();
  }

  if ( $wp_current_db_version < 26148 ) {
    upgrade_372();
 

 View on GitHub View on Trac